Hiding row numbers doesn't remove the column

Example here . I think it could be something to do with the sum. This feels strange!

1 Like

Hi @olammas

Thanks for reporting this issue.

We were able to reproduce this. It’s indeed that when “Sum row” option is ON and “Row number” option OFF, the table creates this extra column to fit the Sum.

My apologies for this strange behavior.

We are working on a fix now. Let me get back with updates later.

1 Like

Hi @olammas,

I apologize for the misinformation in my earlier response.

Upon further review, I want to confirm that it’s our expected behavior for the “Sum Row” & “Average Row” options to generate the label cell in a new column.
This aims to accommodate use-case where the first column is numerical data, allowing it to display the Sum or Average values.

That being said, we still completely agree about the extra column looking odd, and taking up unnecessary space. I have noted this down for the team to discuss improvements.

Let me keep you posted on any update. If you have any further questions or concerns, please let me know. Cheers!


p.s: allow me to change this post to Feature Suggestion type, so we can raise it for more upvotes and ideas

2 Likes